Problem

When running the command “bosboot -ad /dev/ipldevice” in IBM AIX, you get the following error:

0301-150 bosboot: Invalid or no boot device specified!

Solution

A device specified with the bosboot -d command is not valid. The bosboot command was unable to finish processing because it could not locate the required boot device. The installp command calls the bosboot command with /dev/ipldevice. If this error does occur, it is probably because /dev/ipldevice does not exist. /dev/ipldevice is a link to the boot disk.

To determine if the link to the boot device is missing or incorrect :

  1. Verify the link exists:
# ls -l /dev/ipldevice
ls: 0653-341 The file /dev/ipldevice does not exist.
  1. In this case, it does not exist. To identify the boot disk, execute lslv -m hd5. It will show the name of the boot disk:
# lslv -m hd5
hd5:N/A
LP PP1 PV1 PP2 PV2 PP3 PV3
0001 0001 hdisk4 0001 hdisk1

In this example the boot disk name is hdisk4 and hdisk1.

  1. Create a link between the boot device indicated and the /dev/ipldevice file:
# ln /dev/boot_device_name /dev/ipldevice

In my case, I ran:

# ln /dev/rhdisk4 /dev/ipldevice
  1. Now run the bosboot command again:
# bosboot -ad /dev/ipldevice

Example:

# lslv -m hd5;
# ln /dev/rhdisk4 /dev/ipldevice
# bosboot -ad /dev/ipldevice

Tags:

Categories:

Updated:

Leave a comment